With Frame.io C2C, Filmic Pro uploads proxies into your Frame.io Project so you and your team can instantly view takes, organize footage, and start editing. But, eventually, you’ll want to get back to those original, high quality files. This is possible because Filmic Pro will use the same clipname and timecode on the proxy and the original file, making relinking seamless.

In this guide, we’ll walk through how to connect the Filmic Pro C2C proxies back to the original files in various editing tools.

Contents:

Adobe Premiere Pro

Adobe Premiere Pro has tools that enable you to leverage powerful proxy workflows. You can easily relink back to the original files after you’ve started editing, but you can also create a workflow where you can switch between the proxies and the original files on the fly for better performance on your machine.

Relinking

Relinking is the simplest way to move from the C2C proxies to the high resolution originals recorded by Filmic Pro. Let’s step through that process below.

  1. You can begin organizing, logging, and cutting with the C2C proxies.

  2. When you’re ready to relink to your original media, select all the proxy files in your bin you want to relink to the originals. Right click and select “Make Offline”. Make sure you select “Media files remain on disk” and click “OK”.

  3. Selecting the same clips in the bin, right click and select “Link Media”. We’ll need to double check some settings in the Link Media window.

  4. In the Link Media window, under Match File Properties, make sure “File Name” and “Media Start” are checked. The others should be unchecked.

  5. Then, to the right in the Link Media window, make sure “Align Timecode”, “Relink others automatically”, and “Use Media Browser to locate files” are all checked. Click “Locate”.

  6. In the media browser, Premiere Pro will ask you to find the file that matches the one in the Last Path box. Navigate to your high resolution originals and find the corresponding file. Click “OK”.

  7. Premiere Pro will relink all the originals it can find in the current folder. If your originals are across multiple folders, you may have to repeat the process until you locate each set of originals.

Your clips are now relinked to the originals and you can continue your work. If you want the ability to switch between using the proxy files and the originals on the fly (perhaps to help manage performance), you can use Premiere Pro’s proxy workflow. We’ve outlined that workflow below.

Using a Proxy Workflow

Premiere Pro’s proxy workflow allows you to connect both proxy media and original media to the same clip. With both proxies and originals connected, you can switch between them on the fly to better leverage performance in your project and on your computer. This way, you can work with proxies while cutting then switch to the originals when it comes time to render, for example. Here’s how you set that up.

  1. You can begin organizing, logging, and cutting with the C2C proxies.

  2. When you’re ready to connect your original media, select all the proxy files in your bin you want to connect to original media. Right click and select Proxy > Reconnect High Resolution Files. We’ll need to double check some settings in the Reconnect Full Resolution Media window.

  3. In the Reconnect Full Resolution Media window, under Match File Properties, make sure “File Name” and “Media Start” are checked. The others should be unchecked.

  4. Then, to the right in the Reconnect Full Resolution Media window, make sure “Relink others automatically” and “Use Media Browser to locate files” are all checked. Click “Attach”.

  5. In the media browser, Premiere Pro will ask you to find the first file in the list of the Reconnect Full Resolution Media window. If you aren’t sure which file it’s asking you to find, it will tell you in the header of the Reconnect Full Resolution Media window (at the very top). Navigate to your originals and select the corresponding file. Click “OK”.

  6. Premiere Pro will connect all the originals it can find in the current folder to the proxies. If your originals are across multiple folders, you may have to repeat the process until you locate each set of originals.

Your clips are now connected to both the proxies and the original media. You can switch between viewing the proxies and the originals in the Viewer by using the resolution command.

Scaling

If you are linking lower resolution proxies (ie, 1920x1080) to higher resolution originals (ie, 3840x2160) in a sequence that matches the resolution of the proxies, you may have to either rescale the clips or change the resolution of the sequence once they’ve been relinked. If your clips look cropped or “blown up” after relinking, you’ll need to rescale.

To rescale the clips, follow the guide below. This will automatically scale your newly linked originals to the frame size of the sequence.

  1. Select the clips you want to scale in the sequence.

  2. Go to Clip > Video Options > Scale to Frame Size.

If instead you want to change the resolution of the sequence (say, from HD to UHD), follow the guide below.

  1. Select the sequence you want to modify in the bin.

  2. Right click and select Sequence Settings.

  3. In the Sequence Settings window, under Video, change the Frame Size Horizontal and Vertical fields to match your originals.

Final Cut Pro

Different than Premiere Pro, Final Cut Pro combines relinking and proxy workflows into the same concept. When you import clips into Final Cut Pro, it assumes that these clips are originals. We can relink these back to our original files, but then we can also separately re-connect the proxies if we want to use a proxy workflow. We’ll cover both of these below.

Relinking

The first thing we’ll do is just simply relink from our proxies to the original media. Remember, Final Cut Pro assumes that whatever media is imported first is an original.

  1. You can begin organizing, logging, and cutting with the C2C proxies.

  2. When you’re ready to connect your original media, select all the proxy files in your Event you want to connect back to original media. Go to File > Relink Files > Original Media.

  3. You can either select specific clips to relink or click on “Locate All” to relink all clips.

  4. Use Finder to locate your originals. You can select a folder that contains your originals or an individual clip that matches your proxies.

  5. Final Cut Pro will relink all the originals it can find in the current folder to the proxies. If your originals are across multiple folders, you may have to repeat the process until you locate each set of originals. Click “Choose”.

  6. Final Cut Pro will also tell you which clips it was able to relink. Check for errors and click “Relink Files” when ready.

Your clips are now relinked to the original files. If you want the ability to switch between using the proxy files and the originals on the fly, you can use Final Cut Pro’s proxy workflow. We’ve outlined that workflow below.

Using a Proxy Workflow

Just like in Premiere Pro, we can leverage Final Cut Pro’s proxy workflow to connect both the proxy and the original to the same clip. To get started, make sure you’ve already done the Final Cut Pro Relinking process above.

  1. After you’ve relinked your clips to the original media, we can re-attach the proxies. Select all the clips you want to attach proxies to in your Event then go to File > Relink Files > Proxy Media.

  2. You can either select specific clips to relink or click on “Locate All” to relink all clips.

  3. Use Finder to locate your proxies. You can select a folder that contains your proxies or an individual clip that matches your originals.

  4. Final Cut Pro will connect all the proxies it can find in the current folder to the originals. If your proxies are across multiple folders, you may have to repeat the process until you locate each set of proxies. Click “Choose”.

  5. Final Cut Pro will also tell you which clips it was able to connect. Check for errors and click “Relink Files” when ready.

Your clips are now connected to both the proxies and the original media. You can switch between viewing the proxies and the originals in the Viewer by going to View and selecting “Proxy Preferred” or “Proxy Only”.

FILMIC_WF_GUIDE_FCP_VIEW_2.png

Scaling

If you are linking lower resolution proxies (ie, 1920x1080) to higher resolution originals (ie, 3840x2160) in a Project that matches the resolution of the proxies, you may have to either rescale the clips or change the resolution of the Project once they’ve been relinked. If your clips look cropped or “blown up” after relinking, you’ll need to rescale.

To rescale the clips, follow the guide below. This will automatically scale your newly linked originals to the frame size of the Project.

  1. Select the clips you want to scale in the Project.

  2. Open the Inspector by clicking on the icon along the top bar or by pressing CMD + 4.

  3. In the Inspector, expand Spatial Conform by double clicking on it.

  4. Use the dropdown menu under Type to select “Fit”. If “Fit” is already selected, you may need to select it again for Final Cut Pro to apply the scale to the clips.

If instead you want to change the resolution of the Project (say, from HD to UHD), follow the guide below.

  1. Select the Project you want to modify in the Event.

  2. Open the Inspector by clicking on the icon along the top bar or by pressing CMD + 4.

  3. In the Inspector window, select Modify.

  4. In the Project Settings window, use the Video dropdown to select your format (ie, 4K).

  5. Next, under the Resolution dropdown, choose the resolution that matches your originals (ie, 3840x2160).

DaVinci Resolve

In this section, we’ll discuss proxy workflows in DaVinci Resolve as an NLE. If you’re looking for conform information, see the Conform section at the end of this article.

DaVinci Resolve also allows for easy relinking as well as proxy workflows. Similar to Final Cut Pro, you can relink to the original media, then re-attach the proxies if you want to use a proxy workflow. These processes work in both DaVinci Resolve and DaVinci Resolve Studio.

Relinking

The first thing we’ll do in Resolve is relink the proxy files back to the high-resolution originals. This can be done either from the Media Pool page or from the Media Pool panel in the Edit page.

  1. You can begin organizing, logging, and cutting with the C2C proxies.

  2. When you’re ready to connect your original media, select all the proxy files in the Media Pool you want to connect back to original media. Right click and select “Relink Selected Clips”.

  3. Use Finder to locate your originals. Select the folder that contains the originals that match your proxies. Click “Open”.

  4. Resolve will relink all the originals it can find in the current folder to the proxies. If your originals are across multiple folders, you may have to repeat the process until you locate each set of originals.

Your clips are now relinked to the originals and you can continue your work. If you want the ability to switch between using the proxy files and the originals on the fly (perhaps to help manage performance), you can use Resolve’s proxy workflow. We’ve outlined that workflow in the next section.

Note: Resolve also allows the user to change the source folder of selected clips. If you are recording HEVC as your high-resolution original codec in Filmic Pro, this method may work since both the proxies and the originals will be MP4 files. Doing this, however, is not recommended. This tool is designed to tell Resolve to change storage locations of the same media — since the proxies and the originals will have different compressions and resolutions, using this tool may cause issues in your timeline. Instead, it is recommended to use the relink workflow described above.

Using a Proxy Workflow

Once the proxies are relinked back to the high-resolution originals, you can then re-attach your proxies to the relinked clips to use a proxy workflow if desired. To get started, make sure you perform the relinking process outlined in the previous section. Like relinking, this can be done from the Media Pool page or the Media Pool panel in the Edit page.

  1. After you’ve relinked your clips to the original media, we can re-attach the proxies. Select all the clips you want to attach proxies to in the Media Pool then right click and select “Link Proxy Media”.

  2. Use Finder to locate your proxies. Select the folder that contains the proxies that match your originals. Click “Open”.

  3. Resolve will attach all the proxies it can find in the current folder to the originals. If your proxies are across multiple folders, you may have to repeat the process until you locate each set of proxies.

Your clips are now connected to both the proxies and the original media. You can switch between viewing the proxies and the originals in the Viewer by going to Playback > Use Proxy Media if Available.


AVID Media Composer

AVID Media Composer is designed to maintain strong organization through its powerful database. As such, to function properly, it needs media in one of its own native codecs — DNxHD or DNxHR. For Filmic Pro C2C workflows, it is recommended that both the C2C proxies and the high-resolution originals are both processed from their original codecs to a DNxHD or DNxHR flavor that matches the rest of your workflow. This can be done in a dailies tool or in a transcoding tool like Adobe Media Encoder.

Since the Filmic Pro C2C proxies match the high-resolution originals in both clipname and timecode, AVID allows easy relinking between the proxy transcodes and the originals transcodes. In fact, it’s the same relinking process you would use for any other media within AVID Media Composer.

Before beginning the process in this guide, make sure you transcode the Filmic Pro C2C proxies and high-resolution originals into an AVID codec. Both the proxies and the originals should be transcoded into the same codec. For this example, we’ll be using DNxHD 36.

  1. Import your transcoded Filmic Pro C2C proxies into your AVID bin in the method that matches the rest of your AVID workflow. You can begin organizing, logging, and cutting with the C2C proxies.

  2. When you’re ready to relink your original media, place the transcoded originals into a valid “Avid MediaFiles” numbered folder — it’s recommended that you make a new numbered folder for the new media. Be sure not to go back into AVID Media Composer until this media is fully copied into the folder. If it’s helpful, you can quit AVID during this process.

  3. Before going back into AVID Media Composer, remove the transcoded proxy media from its “Avid MediaFiles” numbered folder. (If you don’t know where it lives, you can right click on the clip in the AVID bin and select “Reveal File”.) This can go anywhere, just as long as it’s not in any “Avid MediaFiles” numbered folder. This will make sure AVID Media Composer can no longer see it. It does not have to be deleted.

  4. Go back into or re-open AVID Media Composer and your project. AVID Media Composer will scan the new numbered folder.

  5. Once AVID Media Composer has finished scanning, select all the clips linked to proxy files in the bin you want to relink back to the transcoded original media. Right click and select “Relink”.

  6. In the Relink window, make sure you select the settings that make sense for your configuration. It is recommended that you specify which drive the “Avid MediaFiles” numbered folder with the transcoded originals is under “Media on drive”. Next, it is also recommended to uncheck “Relink only to media from the current project”.

  7. When your relink settings are configured, click “OK”.

  8. Once the clips are relinked, it is recommended to “seal” the “Avid MediaFiles” numbered folder containing the transcoded originals. Leaving AVID Media Composer running, navigate to the numbered folder in Finder or Windows Explorer. Rename the folder to something that either fits into your organizational structure or clearly labels what it contains.

You can now work with AVID files transcoded from the high-resolution originals. The relink process will make sure none of the work you’ve already done with the C2C proxies will be lost and your transition should be seamless. Once your edit is complete, you can conform back to the native high-resolution originals during the online process.

Conform

While each NLE offers a solution for relinking, you don’t have to relink back to the originals. Instead, if you’re already using a color correction or finishing tool (like DaVinci Resolve, Assimilate Scratch, or Autodesk Flame), you can conform back to the high-resolution originals during the online phase. Because the proxies and the originals from Filmic Pro match in clipname and timecode, conforming with C2C-powered workflows is simple and straightforward.

You can export your list of choice (EDL, XML, etc) from your NLE and your finishing tool should be able to conform to the originals. Make sure that your proxies and originals are well organized — if you’re using HEVC as your original codec in Filmic Pro, for example, your proxies and originals will have the exact same filename and extension. This can make it difficult for the finishing tool to conform to the correct files. It is recommended that they are separated into different folders on your hard drive and different bins in your NLE.

Next Articles

Did this answer your question?